Author Topic: 85 tahiti blue (flur continued)  (Read 95330 times)

Online 94touring

Re: 85 tahiti blue (flur continued)
« Reply #25 on: April 17, 2013, 09:41:39 PM »
Fires right up and drives too.  Though my two minute test drive resulted in a broken fan belt, lol. 

Offline Twichel04

Re: 85 tahiti blue (flur continued)
« Reply #26 on: April 17, 2013, 11:00:48 PM »
Really? That was a new belt too... After you came down, she sat in that parking spot for a little over two weeks before I had a chance to go out and start her. Fired right up on the first key turn with no problem and drove surprisingly well for only running on 3 cyls, lol.

Online 94touring

Re: 85 tahiti blue (flur continued)
« Reply #27 on: April 17, 2013, 11:20:35 PM »
Pretty sure that valve is unstuck.  Doesn't seem to be missing.  I have the new crank sensor for it too. 

Offline Twichel04

Re: 85 tahiti blue (flur continued)
« Reply #28 on: April 18, 2013, 11:59:35 AM »
Awesome. I thought it felt a little smoother and peppier when I took her for a final spin around the block. I am actually glad that you already have it sold. I am very anxious to see her restored, and being sold just means that I get to see the progress a little quicker haha.

Online 94touring

Re: 85 tahiti blue (flur continued)
« Reply #29 on: April 18, 2013, 01:03:40 PM »
I already have the paint for it!    Lid shot.

Offline Davisio

Re: 85 tahiti blue (flur continued)
« Reply #30 on: April 28, 2013, 08:00:37 PM »
The color is marvelous. Will really complement the walnut dash and black interior.  71.gif

Must start building the wood/splitter shed to make room in the garage.......  4.gif

Online 94touring

Re: 85 tahiti blue (flur continued)
« Reply #31 on: April 28, 2013, 08:34:24 PM »
I fly to Tulsa tomorrow and will put a couple days into this week.  I start gutting it and hopefully cutting off a lot of metal.

Offline wevebeenhad

Re: 85 tahiti blue (flur continued)
« Reply #32 on: April 29, 2013, 03:45:41 PM »
Great there have not been ANY updates on this site in what feels like 9 years! Glad I will have some fun things to watch be repaired. No thanks to me!

Online 94touring

Re: 85 tahiti blue (flur continued)
« Reply #33 on: April 30, 2013, 04:48:22 PM »
Started dismantling.  Also saw that the water pump took a crap.  Must have siezed up causing the belt to break.  Its leaking from the weap hole pretty good.








Offline Twichel04

Re: 85 tahiti blue (flur continued)
« Reply #34 on: April 30, 2013, 04:59:50 PM »






Holy crap! was that like that the whole time I was driving her?!

Online 94touring

Re: 85 tahiti blue (flur continued)
« Reply #35 on: April 30, 2013, 06:17:22 PM »
Yep!  Surprised me too. 

Offline Twichel04

Re: 85 tahiti blue (flur continued)
« Reply #36 on: April 30, 2013, 06:19:44 PM »
Well that puts all my hard corning into perspective, lol   :-\

Offline Mudhen

Re: 85 tahiti blue (flur continued)
« Reply #37 on: April 30, 2013, 07:06:01 PM »
Well that puts all my hard corning into perspective, lol   :-\

Dude, you're lucky to be alive!  Especially after that track day...  71.gif

Offline Davisio

Re: 85 tahiti blue (flur continued)
« Reply #38 on: April 30, 2013, 07:08:55 PM »
Awesome!


Offline Mudhen

Re: 85 tahiti blue (flur continued)
« Reply #39 on: April 30, 2013, 07:12:46 PM »
Awesome!

You're going to have a whole bunch of VERY cool before and after pics!!!!!!!!!!

Offline Davisio

Re: 85 tahiti blue (flur continued)
« Reply #40 on: April 30, 2013, 07:34:28 PM »
So... that's the front sub-frame?

Busted or rotten?

Or, busted from rotting? Heh.

Online 94touring

Re: 85 tahiti blue (flur continued)
« Reply #41 on: April 30, 2013, 07:42:58 PM »
Don't see any rot on it, just busted right there where the lower engine stabilizer attaches.  I've never seen one do that before. 8.gif

Offline MiniGene

Re: 85 tahiti blue (flur continued)
« Reply #42 on: April 30, 2013, 09:38:20 PM »
What's even more crazy is the axle and dif you pulled off that thing!

Online 94touring

Re: 85 tahiti blue (flur continued)
« Reply #43 on: April 30, 2013, 10:32:49 PM »
What's even more crazy is the axle and dif you pulled off that thing!

Took me the longest time to figure out what you were talking about, lol.  Yes, the previous owner installed a tractor axle and diff.  Probably why the subby broke. 
« Last Edit: April 30, 2013, 11:53:07 PM by 94touring »

Offline Mudhen

Re: 85 tahiti blue (flur continued)
« Reply #44 on: May 01, 2013, 04:15:18 AM »
What's even more crazy is the axle and dif you pulled off that thing!

 :D

Online 94touring

Re: 85 tahiti blue (flur continued)
« Reply #45 on: May 01, 2013, 06:16:19 PM »
Engine off and a few other bits and pieces.  Some of it took some doing and still soaking a couple odds and ends.  The coolant system is going to need a good flush.  The heater and lines going to and from have a lot of sludge.  The new radiator looks nice though!  Will have to drop the rear subby when I get back in a couple weeks.






 

Offline wevebeenhad

Re: 85 tahiti blue (flur continued)
« Reply #46 on: May 01, 2013, 09:43:23 PM »
A COUPLE WEEKS!!!! 11.gif

Online 94touring

Re: 85 tahiti blue (flur continued)
« Reply #47 on: May 08, 2013, 01:02:04 PM »
I know, two weeks feels like a lifetime.  I will have some good time at the end of the month and beginning of next month to knock out a ton of work. 

Offline Davisio

Re: 85 tahiti blue (flur continued)
« Reply #48 on: May 10, 2013, 05:00:30 PM »
Woohoo!!!!

The end of the month begins in 5 days!

:D


Online 94touring

Re: 85 tahiti blue (flur continued)
« Reply #49 on: May 10, 2013, 05:10:28 PM »
I'll be home in a few days to work a couple, then back the 28th to the 7th.  Suspect I will get most if not all the metal work done then.  Then I go on vacation for a week.