Author Topic: Temperature issue with injected engine  (Read 294 times)

Offline tmsmini

  • Moderator
  • 1275cc
  • *****
  • Posts: 278
  • Karma: 1
    • Fremont CA
Temperature issue with injected engine
« on: March 04, 2019, 01:03:40 PM »
I have been holding off on posting this as it just seems such an unlikely problem.

I have a few issues still to sort out with this engine, one of them is the running temperature. It is not your normal A series, but it is an series.
The spec is this:
Block Style, MPi;Head, Calver ST Cylinder Head Super Sports Model: CST2000; Cam, Kent MDM274MPI; Rockers, Forged 1.5; Bore, +10; Flywheel, MPi; Final Drive, 3.1; Differential, Quaife; Speedo, Smiths Electronic; Speedo TPM, Adjustable; Fueling, Specialist Components Typhoon 50 mm TB; Ignition, Specialist Components Typhoon; Radiator, MS C/ARA 4442

I know the MPi block has different oilways and coolant passages, but I don't think this affects that, but it may.

At idle in the driveway, the engine will warm up nicely and if I let it go for over 20 minutes the electric fan will kick in. But as soon as I start moving the temp drops. With ambient temp around 50-55 F/10-13 C, the coolant temp will run about 150 F - 65 C.  This is with the 190 F - 88 C thermostat.

I have checked the gauges as I have both the electronic sensor and the Smiths mechanical gauge as well as a infrared laser version and a radiator cap type to check with.
I have also checked the thermostats and I am actually using a fancy Robert Shaw Flowmaster 195 at the moment with no real change in running temp.

I have a 205 version that I am ready to put in, but that just seems like an extreme step.

The reason this is so critical with the FI engine is that the system will add fuel for warm-up correction. This table can be modified as well and I have made small adjustments, but I would prefer to get the engine running in the 180-190 range.
Terry


Online MiniDave

  • 1380cc
  • *****
  • Posts: 6390
  • Karma: 5
    • Overland Park, Ks
Re: Temperature issue with injected engine
« Reply #1 on: March 04, 2019, 01:28:51 PM »
The only way I can get my '89 carbed Mini to warm up is drive it on a warm to hot day. That's since I put in the aluminum rad in, before that it was a little too warm to my thinking - it ran 3/4 up the gauge on a 65* day - on the highway. So I went to the aluminum radiator, now even on Kansas 100* days it runs right at half way up the gauge.

I'm toying with the idea of blocking the entire grill on cold days, half the grill on warmer days, then opening it up in summer.
1989 Cooper Racing Green
2009 Clubman S
2004 Audi Allroad 2.7 TT

Offline jedduh01

  • 1275cc
  • ****
  • Posts: 414
  • Karma: 1
    • Piedmont Carolina Classic Minis United
Re: Temperature issue with injected engine
« Reply #2 on: March 04, 2019, 02:46:19 PM »
I would consider testing by blocking some of the  grille off,  simple cardboard,. and go for  a test..

Remove some air flow.. Too COOL almost seems strange but 55Degress is chilly!!

Offline tmsmini

  • Moderator
  • 1275cc
  • *****
  • Posts: 278
  • Karma: 1
    • Fremont CA
Re: Temperature issue with injected engine
« Reply #3 on: March 04, 2019, 02:51:28 PM »
I did try this with a piece of plexiglass I had laying around.
It helped a little, but at that point I also had a thermostat that was not closing properly, so i need to retry this.

Offline tmsmini

  • Moderator
  • 1275cc
  • *****
  • Posts: 278
  • Karma: 1
    • Fremont CA
Re: Temperature issue with injected engine
« Reply #4 on: March 04, 2019, 02:54:28 PM »
This is how the engine is laid out.
There is a bypass hose from the heater outlet to the radiator, but that is blocked off while I sort this out. Eventually I will place a flow restrictor in the hose.

Offline 94touring

  • Forum Boss
  • 1380cc
  • ******
  • Posts: 7391
  • Karma: 17
    • Tulsa, OK
    • Restoration-Mini
Re: Temperature issue with injected engine
« Reply #5 on: March 04, 2019, 04:35:04 PM »
I just put a piece of plexi across the front this afternoon, temps now read N at cruise.   I left a small gap for the radiator too. Currently 25 F out

Offline tmsmini

  • Moderator
  • 1275cc
  • *****
  • Posts: 278
  • Karma: 1
    • Fremont CA
Re: Temperature issue with injected engine
« Reply #6 on: March 04, 2019, 05:19:59 PM »
I would expect to have to this in 25 degree weather, but not in 50-60 degree weather I am experiencing.
I wonder if BMC ever had a cold weather running bulletin? They had several for hot weather running.

Offline 94touring

  • Forum Boss
  • 1380cc
  • ******
  • Posts: 7391
  • Karma: 17
    • Tulsa, OK
    • Restoration-Mini
Re: Temperature issue with injected engine
« Reply #7 on: March 04, 2019, 05:27:20 PM »
50s and 60s I run cold too. Has to be 70s and up for me to run N without this new plate.

Offline tmsmini

  • Moderator
  • 1275cc
  • *****
  • Posts: 278
  • Karma: 1
    • Fremont CA
Re: Temperature issue with injected engine
« Reply #8 on: March 04, 2019, 05:31:28 PM »
Maybe I just never paid as close attention before. With the FI, it becomes very critical as a couple of enrichment tables are temp based.

Offline tmsmini

  • Moderator
  • 1275cc
  • *****
  • Posts: 278
  • Karma: 1
    • Fremont CA
Re: Temperature issue with injected engine
« Reply #9 on: May 31, 2019, 11:28:10 AM »
Just a minor update, I have tried the 205/96 thermostat and the engine warms up very quickly. It seem to be ok around town, getting to 190/88 at stop lights, but dropping once moving. I have the aux fan set to kick in at 203/95 and it has not come on in traffic yet. I think this thermostat is probably too warm for regular running and I would like to find a 200/94 thermostat, but I have not had any luck with that. It has been a little colder than usual this spring, but should warm in the next week, so I will be able to test it on the road better.

Offline Jimini II

  • 1071cc
  • ***
  • Posts: 232
  • Karma: 0
Re: Temperature issue with injected engine
« Reply #10 on: May 31, 2019, 03:09:37 PM »
Just a thought I am not sure where you are looking for thermostats and maybe you already know that small block Chevy thermostats fit our Minis, maybe there is a better selection of those.

Offline MPlayle

  • CREW
  • 1380cc
  • *****
  • Posts: 1941
  • Karma: 1
    • San Antonio, Texas
Re: Temperature issue with injected engine
« Reply #11 on: May 31, 2019, 03:21:56 PM »
If you use the cross reference of a 1973 MG Midget, you can find 195/91 thermostats at Autozone.  Other standard auto parts places will also likely have it under that same cross reference.


Offline tmsmini

  • Moderator
  • 1275cc
  • *****
  • Posts: 278
  • Karma: 1
    • Fremont CA
Re: Temperature issue with injected engine
« Reply #12 on: May 31, 2019, 03:47:50 PM »
Thanks for the tip. Steve at Seven Ent had suggested this to me awhile back. I tried a number of the more expensive versions, Robert Shaw, Master Kooler and others, but all under 200, not thinking I would need anything hotter. Now I have a good number of spares for my son's 67 El Camino.

I have not been able to find a 200 degree version for the SBC. Lots cooler and a few hotter, but none at 200.

Made a trip to the hardware store with outside temps a little over 80/27. Car ran between 90/194-95/203 and went to 100/212 at the stop signs. Gauge in the car reads in Celsius.
The gauge is relatively accurate to 90, but reads hot after that.

Offline tmsmini

  • Moderator
  • 1275cc
  • *****
  • Posts: 278
  • Karma: 1
    • Fremont CA
Re: Temperature issue with injected engine
« Reply #13 on: June 03, 2019, 01:32:29 PM »
I am trying to be more consistent with making changes, but managing all the variables is not easy.
I am guessing the majority of British cars use the same thermostats as it looks like the the B is the same as the Midget.

I bought some of the more expensive SBC versions to try. I have since read on the hot rod forums that these were very good a few years ago but are no longer as good.
Everything is relative.

I found that while most opened at close to the rated temperature, many were slow to close when the temp dropped.

Offline tmsmini

  • Moderator
  • 1275cc
  • *****
  • Posts: 278
  • Karma: 1
    • Fremont CA
Re: Temperature issue with injected engine
« Reply #14 on: June 11, 2019, 11:39:27 AM »
Just an update with hotter weather on hand, basically the same maybe running a little hotter due to the 85-90 F outside temps with one trip at the 100 F mark.

Car ran between 95/203 and went to 100/212 at the stop signs, sometimes a little over. Gauge in the car reads in Celsius.
So the 205 F thermostat works well as it warms up quickly, but definitely not much overhead safety if I was running under load at these temps like climbing a hill. Around town we seem to be fine as temp drops to 90/194 when moving.

I am frustrated by the accuracy of the mechanical gauges at this point as this one over reads.

When we get back from Colorado, I have some work to do to sort this out.